package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\/(computers|notebook|apple)\/(.*?\/)?(.*?).html$`)
var str = `/computers/asus400.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}