re = /^\/(computers|notebook|apple)\/(.*?\/)?(.*?).html$/
str = '/computers/asus400.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end