const regex = /,(?=(?:[^""]*""[^""]*"")*(?![^""]*""))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?=(?:[^""]*""[^""]*"")*(?![^""]*""))', 'g')
const str = `CANADIAN PACIFIC HOTELS B.V.;Branch / Legal Entity;A0060201;24153390;NL001463743B01;Joan Muyskenweg 10;1096;CJ Amsterdam;NL;00602.S0010;130_CE_CANADIAN PACIFIC HOTELS INTERN dfgdsgg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}