package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[-'’\p{L}\p{M}]+`)
var str = `Crêpes are øh-so déclassée`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}