$re = '/[-\'’\p{L}\p{M}]+/iu';
$str = 'Crêpes are øh-so déclassée';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);