package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\d\.]+)(.*)`)
var str = `1234picas
1234 px
145.4us`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}