$re = '/([\d\.]+)(.*)/';
$str = '1234picas
1234 px
145.4us';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);