package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+),|(\D+\d*,?\d*),`)
var str = `a,b,c 1,2,abc
a 1,c,f,d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}