$re = '/(\w+),|(\D+\d*,?\d*),/m';
$str = 'a,b,c 1,2,abc
a 1,c,f,d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);