using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|;)([^;""]*)(?!"")|""([^""]+)""";
string input = @"15;""RM EG Flur bei; Zi.217-222"";;123;Feuer;;Standard;Analog/AM;4;ÜE 1 (direkt)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}