re = /(?:^|;)([^;"]*)(?!")|"([^"]+)"/m
str = '15;"RM EG Flur bei; Zi.217-222";;123;Feuer;;Standard;Analog/AM;4;ÜE 1 (direkt)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end