package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)>(?<message_value>[^\<]+)<`)
var str = `<*Message>This is what I want to capture.<*/Message>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}