$re = '/>(?<message_value>[^\<]+)</m';
$str = '<*Message>This is what I want to capture.<*/Message>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);