#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)example.com\/account\/(|.*\#home\.html|(\?(?!.*#.*)))$"
Local $sString = "example.com/account/" & @CRLF & _
"example.com/account/?brand=mine" & @CRLF & _
"example.com/account/#home.html" & @CRLF & _
"example.com/account/?brand=mine#home.html" & @CRLF & _
"example.com/account/#other.html" & @CRLF & _
"example.com/account/?brand=mine#other.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")