const regex = /example.com\/account\/(|.*\#home\.html|(\?(?!.*#.*)))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('example.com\\\/account\\\/(|.*\\#home\\.html|(\\?(?!.*#.*)))$', 'gm')
const str = `example.com/account/
example.com/account/?brand=mine
example.com/account/#home.html
example.com/account/?brand=mine#home.html
example.com/account/#other.html
example.com/account/?brand=mine#other.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}