# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<section[a-z="'\s]+>([\s\S]*?)<\\/section>)/$1/gmi;t' <<< "<chapter id=\"chap1\">
<para0><title></title></para0>
</chapter>
<chapter id=\"chap2\"> <title>THEORY</title>
<section id=\"Thoery\">
<title>theory Section</title>
<para0 verstatus=\"ver\">
<title>Theory Para 0 </title>
<text>blah blah</text>
</para0>
</section>
<section id=\"Next section\">
<title>title</title>
<para0>
<title>Title</title>
<text>blah blah</text>
</para0>
</section>
<section id=\"More sections\">
<title>title</title>
<para0>
<title>Title</title>
<text>blah blah</text>
</para0>
</section>
<section id=\"section\">
<title>title</title>
<para0>
<title>Title</title>
<text>blah blah</text>
</para0>
</section>"