import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<section[a-z=\"'\\s]+>([\\s\\S]*?)<\\/section>)";
final String string = "<chapter id=\"chap1\">\n"
+ "<para0><title></title></para0>\n"
+ "</chapter>\n\n"
+ "<chapter id=\"chap2\"> <title>THEORY</title>\n"
+ "<section id=\"Thoery\">\n"
+ "<title>theory Section</title>\n"
+ "<para0 verstatus=\"ver\">\n"
+ "<title>Theory Para 0 </title>\n"
+ "<text>blah blah</text>\n"
+ "</para0>\n"
+ "</section>\n\n"
+ "<section id=\"Next section\">\n"
+ "<title>title</title>\n"
+ "<para0>\n"
+ "<title>Title</title>\n"
+ "<text>blah blah</text>\n"
+ "</para0>\n"
+ "</section>\n\n"
+ "<section id=\"More sections\">\n"
+ "<title>title</title>\n"
+ "<para0>\n"
+ "<title>Title</title>\n"
+ "<text>blah blah</text>\n"
+ "</para0>\n"
+ "</section>\n\n"
+ "<section id=\"section\">\n"
+ "<title>title</title>\n"
+ "<para0>\n"
+ "<title>Title</title>\n"
+ "<text>blah blah</text>\n"
+ "</para0>\n"
+ "</section>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}