import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\((\\d)(?!\\1{2}\\)\\1{3}-\\1{4}$)\\d{2}\\)\\d{3}-\\d{4}$";
final String string = "(888)123-1234\n"
+ "(886)123-1234\n"
+ "(666)666-6666";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}