const regex = /^\((\d)(?!\1{2}\)\1{3}-\1{4}$)\d{2}\)\d{3}-\d{4}$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\((\\d)(?!\\1{2}\\)\\1{3}-\\1{4}$)\\d{2}\\)\\d{3}-\\d{4}$', 'mg')
const str = `(888)123-1234
(886)123-1234
(666)666-6666`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}