#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+:\/\/(?:\w+@)?([\w\-\.]+)"
Local $sString = "http://falloutboy.com/" & @CRLF & _
"http://xn----7sbajjbec0dd3k7b.xn--p1ai/vse_serii_podryad/multiki" & @CRLF & _
"http://www.adobe.com/ru/" & @CRLF & _
"http://www.mamba.ru/en/" & @CRLF & _
"http://lurkmore.to/%D0%90%D0%BA%D1%83%D0%BD%D0%B8%D0%BD" & @CRLF & _
"https://ru.bongacams.com/" & @CRLF & _
"http://user@example.com" & @CRLF & _
"https://en.wikipedia.org/wiki/Java_version_history" & @CRLF & _
"http://rutor.info/" & @CRLF & _
"https://www.youtube.com/user/momondo" & @CRLF & _
"http://totori.ru/bezdomnyj-bog-2-sezon-12-seriya" & @CRLF & _
"http://xn-----7kcabbec2afz1as3apmjtgqh4hrf.xn--p1ai/dlya-komyutera/viber-dlya-windows-7" & @CRLF & _
"http://lurkmore.to/%D0%90%D0%BA%D1%83%D0%BD%D0%B8%D0%BD" & @CRLF & _
"http://www.povarenok.ru/recipes/show/42046/" & @CRLF & _
"http://blog.t-stile.info/v-vashem-aktive-net-inostrannyx-yazykov-ne-kruchintes" & @CRLF & _
"http://www.bibo.kz/aforizmi/393836--chto-pervichno-jajjco-ili-kurica-.html" & @CRLF & _
"https://yandex.ru/search/?lr=2&clid=2233330&win=195&msid=1485784820.7601.20943.16306&text=самый%20первый%20фильм%20в%20мире&example_source=all&nl=1" & @CRLF & _
"http://lib.mexmat.ru:80/books/90359"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")