using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+:\/\/(?:\w+@)?([\w\-\.]+)";
string input = @"http://falloutboy.com/
http://xn----7sbajjbec0dd3k7b.xn--p1ai/vse_serii_podryad/multiki
http://www.adobe.com/ru/
http://www.mamba.ru/en/
http://lurkmore.to/%D0%90%D0%BA%D1%83%D0%BD%D0%B8%D0%BD
https://ru.bongacams.com/
http://user@example.com
https://en.wikipedia.org/wiki/Java_version_history
http://rutor.info/
https://www.youtube.com/user/momondo
http://totori.ru/bezdomnyj-bog-2-sezon-12-seriya
http://xn-----7kcabbec2afz1as3apmjtgqh4hrf.xn--p1ai/dlya-komyutera/viber-dlya-windows-7
http://lurkmore.to/%D0%90%D0%BA%D1%83%D0%BD%D0%B8%D0%BD
http://www.povarenok.ru/recipes/show/42046/
http://blog.t-stile.info/v-vashem-aktive-net-inostrannyx-yazykov-ne-kruchintes
http://www.bibo.kz/aforizmi/393836--chto-pervichno-jajjco-ili-kurica-.html
https://yandex.ru/search/?lr=2&clid=2233330&win=195&msid=1485784820.7601.20943.16306&text=самый%20первый%20фильм%20в%20мире&example_source=all&nl=1
http://lib.mexmat.ru:80/books/90359";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}