const regex = new RegExp('^((?!known-to-fail|env_browser).)*$', 'gm')
const str = `["known-to-fail", "env_ci", "env_local"]
["non-exclusive", "env_browser", "env_local"]
["env_ci"]
["env_ci", "env_local", "known-to-fail"]
["env_ci", "env_local"]
[]
""`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}