$re = '/^[0-9]{4}\-[0-9]{4}\-[0-9]{4}\-[0-9]{4}$/';
$str = '0000-1111-2222-3333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);