#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-+]?[0-9]+(\.[0-9]+)?[[:space:]]?[CFcf]?$"
Local $sString = "13" & @CRLF & _
"102" & @CRLF & _
"97.0" & @CRLF & _
"-4.28" & @CRLF & _
"11.25" & @CRLF & _
"+8" & @CRLF & _
"0.015" & @CRLF & _
"19 c" & @CRLF & _
"19F" & @CRLF & _
"32C" & @CRLF & _
"-17.20 c" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")