re = /^[-+]?[0-9]+(\.[0-9]+)?[[:space:]]?[CFcf]?$/m
str = '13
102
97.0
-4.28
11.25
+8
0.015
19 c
19F
32C
-17.20 c
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end