const regex = /^(?!\/rails).*(?:jpg|jpeg|gif|css|png|js|ico|json|xml|txt|html)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\\/rails).*(?:jpg|jpeg|gif|css|png|js|ico|json|xml|txt|html)$', 'gm')
const str = `/rails/randomstring/image.png
/randomstring/image.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}