re = /^(?!\/rails).*(?:jpg|jpeg|gif|css|png|js|ico|json|xml|txt|html)$/m
str = '/rails/randomstring/image.png
/randomstring/image.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end