package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)\d+\.(?:pn|jp)g`)
var str = `asdasd123.jpg.jpg
dsds345.png.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}