$re = '/(?i)\d+\.(?:pn|jp)g/m';
$str = 'asdasd123.jpg.jpg
dsds345.png.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);