#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^(]|\(#{1,3}\)"
Local $sString = "Going" & @CRLF & _
"(#)" & @CRLF & _
"(maybe)" & @CRLF & _
"to" & @CRLF & _
"the" & @CRLF & _
"(##)" & @CRLF & _
"(mall)" & @CRLF & _
"market"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")