package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^(]|\(#{1,3}\)`)
var str = `Going
(#)
(maybe)
to
the
(##)
(mall)
market`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}