# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\d{2})(?:\:\d{2}){2}).*?\[\s(\d+).*?\[\s(\d+)/\1,\2,\3/gm;t' <<< "Line 394 : [21:44:07 Oct 12 Fri] @0x3924004E|JVM| Free Memory: Heap [ 2368340/ 6291456], Native[ 7299824/32505856]"