$re = '/((?:\d{2})(?:\:\d{2}){2}).*?\[\s(\d+).*?\[\s(\d+)/m';
$str = 'Line 394 : [21:44:07 Oct 12 Fri] @0x3924004E|JVM| Free Memory: Heap [ 2368340/ 6291456], Native[ 7299824/32505856]';
$subst = "\1,\2,\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;