using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*(?:error|warning|line).*).*?(?<file>\w+\.\w+).*?(?<line>\d+)";
string input = @"filename.c:54:9: error: use of undeclared identifier 'foo'
File ""main.py"", line 664, in Run
points_lib.cpp:553:56: error: cannot convert ‘std::vector<std::vector<std::vector<int> > >’ to ‘int’ for argument ‘3’ to ‘void CellsInCircle(int, float, int)’";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}