$re = '/(?=.*(?:error|warning|line).*).*?(?<file>\w+\.\w+).*?(?<line>\d+)/';
$str = 'filename.c:54:9: error: use of undeclared identifier \'foo\'
File "main.py", line 664, in Run
points_lib.cpp:553:56: error: cannot convert ‘std::vector<std::vector<std::vector<int> > >’ to ‘int’ for argument ‘3’ to ‘void CellsInCircle(int, float, int)’';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);