using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=[\s\S]*\berror\b)(?=[\s\S]*\balarm\b)[\s\S]*";
string input = @"ns1.alarm.abc
ns2.error.cdb";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}