re = /(?=[\s\S]*\berror\b)(?=[\s\S]*\balarm\b)[\s\S]*/
str = 'ns1.alarm.abc
ns2.error.cdb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end