import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[^\\d-\\s][\\w-]+\\b";
final String string = "black PENS Assorted Bit Set 10Pcs \n"
+ "Hollow blocks 10-16mm Cd3 \n"
+ "Hollow blocks 16-23mm Cd3 \n"
+ "Hollow blocks 5-10mm Cd3 \n"
+ "Hollow blocks To 1-5mm Cd3 a10-333\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}