re = /\b[^\d-\s][\w-]+\b/mi
str = 'black PENS Assorted Bit Set 10Pcs
Hollow blocks 10-16mm Cd3
Hollow blocks 16-23mm Cd3
Hollow blocks 5-10mm Cd3
Hollow blocks To 1-5mm Cd3 a10-333
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end