// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\s\S]*\\underline{(.*?)} (.*)}[\s\S]*verifiëren & ([\s\S]*?) \\\\[\s\S]*").unwrap();
let string = "% 14
\\item \\textbf{\\underline{Belangrijk:} Het systeem moet de gebruiker in staat stellen aanpasbare drempelwaarden voor de vitale functies van de patiënt in te stellen, zodat automatische waarschuwingen naar de zorgverlener worden gestuurd wanneer de vitale functies van de patiënt buiten deze drempelwaarden vallen, en automatisch gebeurtenissen worden opgenomen (8)}
\\begin{table}[ht]
\\centering
\\begin{tblr}{
colspec={X[l]X[l]},
row{1}={bg=gray!20},
row{even}={bg=gray!10},
row{1}={font=\\bfseries},
}
Criteria & \\\\
\\toprule
Moeilijkheid taak (voor gebruiker) & Makkelijk/Gemiddeld/Moeilijk \\\\
Stappen om te verifiëren & 1. Verifieer dat het dashboard toegankelijk is
\\newline 2. Verifieer dat alle streams verbonden zijn en live zijn \\\\
Problemen, indien aanwezig tijdens het uitvoeren van de taak & \\\\
Is het gewenste resultaat bereikt? & \\\\
Aanvullende test- en validatiemethoden & \\\\
Overige opmerkingen & \\\\
\\bottomrule
\\end{tblr}
\\end{table}
";
let substitution = "\\\\repeatTable\\n {$1}\\n {$2}\\n {$3}\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}