import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Equipment>[\\s\\S]+?<\\/Equipment>";
final String string = "<soapenv:Envelope xmlns:soapenv=\"http://schemas.xmlsoap.org/soap/envelope/\" xmlns:soapenc=\"http://schemas.xmlsoap.org/soap/encoding/\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\">\n"
+ " <soapenv:Header/>\n"
+ " <soapenv:Body>\n"
+ " <p237:getNewSampleSerialNumsOutput xmlns:p237=\"http://www.cat.com/sos/2008/07/15/EquipmentService/\">\n"
+ " <Equipment>\n"
+ " <p463:serialNumber xmlns:p463=\"http://www.cat.com/dds/Equipment/2008/07/15\">ZBD11674</p463:serialNumber>\n"
+ " <p463:make xsi:nil=\"true\" xmlns:p463=\"http://www.cat.com/dds/Equipment/2008/07/15\"/>\n"
+ " </Equipment>\n"
+ " <Equipment>\n"
+ " <p463:serialNumber xmlns:p463=\"http://www.cat.com/dds/Equipment/2008/07/15\">ZBF11179</p463:serialNumber>\n"
+ " <p463:make xsi:nil=\"true\" xmlns:p463=\"http://www.cat.com/dds/Equipment/2008/07/15\"/>\n"
+ " </Equipment>\n"
+ " <Equipment>\n"
+ " <p463:serialNumber xmlns:p463=\"http://www.cat.com/dds/Equipment/2008/07/15\">ZBF11507</p463:serialNumber>\n"
+ " <p463:make xsi:nil=\"true\" xmlns:p463=\"http://www.cat.com/dds/Equipment/2008/07/15\"/>\n"
+ " </Equipment>\n"
+ " </p237:getNewSampleSerialNumsOutput>\n"
+ " </soapenv:Body>\n"
+ "</soapenv:Envelope>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}