# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<Equipment>[\s\S]+?<\/Equipment>"
test_str = ("<soapenv:Envelope xmlns:soapenv=\"http://schemas.xmlsoap.org/soap/envelope/\" xmlns:soapenc=\"http://schemas.xmlsoap.org/soap/encoding/\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\">\n"
" <soapenv:Header/>\n"
" <soapenv:Body>\n"
" <p237:getNewSampleSerialNumsOutput xmlns:p237=\"http://www.cat.com/sos/2008/07/15/EquipmentService/\">\n"
" <Equipment>\n"
" <p463:serialNumber xmlns:p463=\"http://www.cat.com/dds/Equipment/2008/07/15\">ZBD11674</p463:serialNumber>\n"
" <p463:make xsi:nil=\"true\" xmlns:p463=\"http://www.cat.com/dds/Equipment/2008/07/15\"/>\n"
" </Equipment>\n"
" <Equipment>\n"
" <p463:serialNumber xmlns:p463=\"http://www.cat.com/dds/Equipment/2008/07/15\">ZBF11179</p463:serialNumber>\n"
" <p463:make xsi:nil=\"true\" xmlns:p463=\"http://www.cat.com/dds/Equipment/2008/07/15\"/>\n"
" </Equipment>\n"
" <Equipment>\n"
" <p463:serialNumber xmlns:p463=\"http://www.cat.com/dds/Equipment/2008/07/15\">ZBF11507</p463:serialNumber>\n"
" <p463:make xsi:nil=\"true\" xmlns:p463=\"http://www.cat.com/dds/Equipment/2008/07/15\"/>\n"
" </Equipment>\n"
" </p237:getNewSampleSerialNumsOutput>\n"
" </soapenv:Body>\n"
"</soapenv:Envelope>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.