import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(?:\\bId="\\d+"\\b|\\b4[78][0-9]{14}\\b)).*?(\\bhello\\b|\\b49[0-9]{14}\\b)";
final String string = "Id="4912345678912345"\n"
+ "Id="4712345678912345"\n"
+ "4712345678912345\n"
+ "4912345678912345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}