const regex = /^(?!.*(?:\bId="\d+"\b|\b4[78][0-9]{14}\b)).*?(\bhello\b|\b49[0-9]{14}\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*(?:\\bId="\\d+"\\b|\\b4[78][0-9]{14}\\b)).*?(\\bhello\\b|\\b49[0-9]{14}\\b)', 'gm')
const str = `Id="4912345678912345"
Id="4712345678912345"
4712345678912345
4912345678912345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}