using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">[\s\n]{0,}<img";
string input = @"> <img
>
<img
>щ<img
>g<img";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}