using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"new\s+(?:Worker|SharedWorker)\s*\(\s*new\s+URL.+?import\.meta\.url";
string input = @"new Worker(new URL import.meta.url 1111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}