package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)new\s+(?:Worker|SharedWorker)\s*\(\s*new\s+URL.+?import\.meta\.url`)
var str = `new Worker(new URL import.meta.url 1111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}