re = /(?<!\w)(\(?(\+|00)?48\)?)?[ -]?\d{3}[ -]?\d{3}[ -]?\d{3}(?!\w)/
str = '+48 123 456 789
123456789
123 456 789
123-456-789
(+48) 123 456 789
+48123456789
0048123456789
Things not to capture:
12 345 67 89
1234567899876543211
654564654654654654
spam
1231312asdasdf1231231
123321
+4863227124'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end