$re = '/MinorAlleleCount:\K\S+/';
$str = 'text text SomeMinorAlleleCount:G=0.4627/56166 text text text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);