re = /MinorAlleleCount:\K\S+/
str = 'text text SomeMinorAlleleCount:G=0.4627/56166 text text text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end